11 giugno 2008

EN - Fear

Sometimes happens that from a moment to another you feel lost. That's what happened to me two days ago while i was helping in testing an issue that devs found in booting vista after installing openSUSE 11.0 RC1.

While my test resulted in a successful boot of vista after installing RC1 (marking the bug as WORKSFORME) to perform this test i had to clean my good old 10.3 setup that was working perfectly. I didn't had though the intention of using openSUSE 11.0 RC1 as my main system, and for this reason i managed to get enough free space on my 200GB LACIE USB hard drive and, with the help of partedmagic live CD i have created gzipped images of my / and /home using the partimage program.

Trusting it enough, after getting the two partitions gzipped into my LACIE i rebooted straight into the vista's install DVD to try to restore the MBR, just to simulate a first install. It did not working, and i gave just half an our to investigate the problem. After those 30 minutes i abandonned the idea of restoring the original way vista lads after powering on he machine. it was causing me to get nervous.

So i booted with the openSUSE 11.0 RC1 DVD and walked to the shiny new installation procedure witch is really splendid. Everything went fine, i have noted some good news (but that will be in another post) and new, pleasant, performance in speed.

Installation was a breeze, kde 4.0 is branded just fine and upgrades to 4.1 will be available pretty soon after KDE community release it. OK good, vista booted without problems (but notice that 10.3 was installed before and the problem can e related to an original install of vista, without modification to the MBR) and was time to get back to my 10.3 saved images so i rebooted into parted magic live CD, connected and mounted my LACIE and started partimage to restore the images.

At this point i thought i was to start to destroy everyting on my desktop, the real one, with my baseball bat when partimage said that the image i saved just the day before, with the same version of the software from the same live CD, had was compressed in a way it wasn't able to restore my files from.

This happened for the / image as well for the /home image, and you can think about my mood and i don't wish it even to my enemies. But after a little sweat i jumped to partimage's forums and found that this was a known but and to restore this images i should uncompress them manually with gzip from command line and then restore them as uncompressed images.

Everything went into place and now my system, frozen for a night, is working just like when i shooted it down before saving images. So now you know:

Do not save compressed images with partimage 0.6.7, it won't restore them unless you uncompress them manually!!

And don't say you weren't warned...

Posta un commento